use strict;
my $str = 'Walter & Cooper';
my $regex = qr/(?!\w.*>)(&)(?=.*<\/)/p;
my $subst = 'result context-3="131180" context-ui-effect="key-change" control-mode="bns" /';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";