re = /(?!\w.*>)(&)(?=.*<\/)/
str = 'Walter & Cooper'
subst = 'result context-3="131180" context-ui-effect="key-change" control-mode="bns" /'
result = str.sub(re, subst)
# Print the result of the substitution
puts result