const regex = /(?!\w.*>)(&)(?=.*<\/)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!\\w.*>)(&)(?=.*<\\\/)', '')
const str = `Walter & Cooper`;
const subst = `result context-3="131180" context-ui-effect="key-change" control-mode="bns" /`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);