import re
regex = re.compile(r"(?!\w.*>)(&)(?=.*<\/)")
test_str = "Walter & Cooper"
subst = "result context-3=\"131180\" context-ui-effect=\"key-change\" control-mode=\"bns\" /"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)