#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?P<response_time>\s\d+\.\d+\s)"
Local $sString = "192.168.1.1 - - [08/Sep/2014:15:15:15 +0100] "GET / HTTP/1.0" 200 612 "-" "-" 4.038 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")