import Foundation
let pattern = #"(?P<response_time>\s\d+\.\d+\s)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"192.168.1.1 - - [08/Sep/2014:15:15:15 +0100] "GET / HTTP/1.0" 200 612 "-" "-" 4.038 "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}