// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?P<response_time>\s\d+\.\d+\s)").unwrap();
let string = "192.168.1.1 - - [08/Sep/2014:15:15:15 +0100] \"GET / HTTP/1.0\" 200 612 \"-\" \"-\" 4.038 ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}