re = /(?P<response_time>\s\d+\.\d+\s)/
str = '192.168.1.1 - - [08/Sep/2014:15:15:15 +0100] "GET / HTTP/1.0" 200 612 "-" "-" 4.038 '
# Print the match result
str.match(re) do |match|
puts match.to_s
end