package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<response_time>\s\d+\.\d+\s)`)
var str = `192.168.1.1 - - [08/Sep/2014:15:15:15 +0100] "GET / HTTP/1.0" 200 612 "-" "-" 4.038 `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}