# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<et>.*)\brpg\b/$1rts/g;t' <<< "<et>A rpg</et>
<et>B rpg</et>
<et>C rpg</et>
<et>D rpg</et>
<et>E rpg</et>
<et>F rpg</et>"