use strict;
my $str = '<et>A rpg</et>
<et>B rpg</et>
<et>C rpg</et>
<et>D rpg</et>
<et>E rpg</et>
<et>F rpg</et>';
my $regex = qr/(<et>.*)\brpg\b/p;
my $subst = '$1rts';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";