re = /(<et>.*)\brpg\b/
str = '<et>A rpg</et>
<et>B rpg</et>
<et>C rpg</et>
<et>D rpg</et>
<et>E rpg</et>
<et>F rpg</et>'
subst = '$1rts'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result