import Foundation
let pattern = #"(<et>.*)\brpg\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<et>A rpg</et>
<et>B rpg</et>
<et>C rpg</et>
<et>D rpg</et>
<et>E rpg</et>
<et>F rpg</et>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1rts"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)