import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<et>.*)\\brpg\\b";
final String string = "<et>A rpg</et>\n"
+ "<et>B rpg</et>\n"
+ "<et>C rpg</et>\n"
+ "<et>D rpg</et>\n"
+ "<et>E rpg</et>\n"
+ "<et>F rpg</et>";
final String subst = "$1rts";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}