// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(<et>.*)\brpg\b").unwrap();
let string = "<et>A rpg</et>
<et>B rpg</et>
<et>C rpg</et>
<et>D rpg</et>
<et>E rpg</et>
<et>F rpg</et>";
let substitution = "$1rts";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}