# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<et>.*)\brpg\b"
test_str = ("<et>A rpg</et>\n"
"<et>B rpg</et>\n"
"<et>C rpg</et>\n"
"<et>D rpg</et>\n"
"<et>E rpg</et>\n"
"<et>F rpg</et>")
subst = "$1rts"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.