package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<et>.*)\brpg\b`)
var str = `<et>A rpg</et>
<et>B rpg</et>
<et>C rpg</et>
<et>D rpg</et>
<et>E rpg</et>
<et>F rpg</et>`
var substitution = "$1rts"
fmt.Println(re.ReplaceAllString(str, substitution))
}