# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([,.] *)(<\\/(?:a|b|em|i|strong)>)/\2\1/g;t' <<< "<p>Lorem ipsum dolor sit <em>amet, </em>consectetur adipiscing elit.</p>"