use strict;
my $str = '<p>Lorem ipsum dolor sit <em>amet, </em>consectetur adipiscing elit.</p>';
my $regex = qr/([,.] *)(<\/(?:a|b|em|i|strong)>)/p;
my $subst = '\\2\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";