const regex = /([,.] *)(<\/(?:a|b|em|i|strong)>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([,.] *)(<\\\/(?:a|b|em|i|strong)>)', 'g')
const str = `<p>Lorem ipsum dolor sit <em>amet, </em>consectetur adipiscing elit.</p>`;
const subst = `\2\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);