import Foundation
let pattern = #"([,.] *)(<\/(?:a|b|em|i|strong)>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<p>Lorem ipsum dolor sit <em>amet, </em>consectetur adipiscing elit.</p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)