package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([,.] *)(<\/(?:a|b|em|i|strong)>)`)
var str = `<p>Lorem ipsum dolor sit <em>amet, </em>consectetur adipiscing elit.</p>`
var substitution = "\2\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}