using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([,.] *)(<\/(?:a|b|em|i|strong)>)";
string substitution = @"\2\1";
string input = @"<p>Lorem ipsum dolor sit <em>amet, </em>consectetur adipiscing elit.</p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}