$re = '/([,.] *)(<\/(?:a|b|em|i|strong)>)/';
$str = '<p>Lorem ipsum dolor sit <em>amet, </em>consectetur adipiscing elit.</p>';
$subst = "\2\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;