# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+.*?)(?:\s+(-)\s+)(.*?\d+)/$1$2$3/gmi;t' <<< "12 - 23
12 - -23
-12 - 23
-12 - -23"