$re = '/(\d+.*?)(?:\s+(-)\s+)(.*?\d+)/mi';
$str = '12 - 23
12 - -23
-12 - 23
-12 - -23';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;