use strict;
my $str = '12 - 23
12 - -23
-12 - 23
-12 - -23';
my $regex = qr/(\d+.*?)(?:\s+(-)\s+)(.*?\d+)/mip;
my $subst = '$1$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";