#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(\d+.*?)(?:\s+(-)\s+)(.*?\d+)"
Local $sString = "12 - 23" & @CRLF & _
"12 - -23" & @CRLF & _
"-12 - 23" & @CRLF & _
"-12 - -23"
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)