package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(\d+.*?)(?:\s+(-)\s+)(.*?\d+)`)
var str = `12 - 23
12 - -23
-12 - 23
-12 - -23`
var substitution = "$1$2$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}