#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)digits-range-(\d+)-(\d+)?$"
Local $sString = "digits-range-1-10000" & @CRLF & _
"digits-range-2-" & @CRLF & _
"digits-range-1-10000-234" & @CRLF & _
"digits-range-1.5-2.5" & @CRLF & _
"diginge-1-10000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")