$re = '/digits-range-(\d+)-(\d+)?$/m';
$str = 'digits-range-1-10000
digits-range-2-
digits-range-1-10000-234
digits-range-1.5-2.5
diginge-1-10000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);