const regex = /digits-range-(\d+)-(\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('digits-range-(\\d+)-(\\d+)?$', 'gm')
const str = `digits-range-1-10000
digits-range-2-
digits-range-1-10000-234
digits-range-1.5-2.5
diginge-1-10000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}