use strict;
my $str = 'digits-range-1-10000
digits-range-2-
digits-range-1-10000-234
digits-range-1.5-2.5
diginge-1-10000';
my $regex = qr/digits-range-(\d+)-(\d+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}