re = /digits-range-(\d+)-(\d+)?$/m
str = 'digits-range-1-10000
digits-range-2-
digits-range-1-10000-234
digits-range-1.5-2.5
diginge-1-10000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end