using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"digits-range-(\d+)-(\d+)?$";
        string input = @"digits-range-1-10000
digits-range-2-
digits-range-1-10000-234
digits-range-1.5-2.5
diginge-1-10000";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}