import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "digits-range-(\\d+)-(\\d+)?$";
        final String string = "digits-range-1-10000\n"
	 + "digits-range-2-\n"
	 + "digits-range-1-10000-234\n"
	 + "digits-range-1.5-2.5\n"
	 + "diginge-1-10000";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}