#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?U)(C:(?:\\.+){8}(?:\\|\n|$))"
Local $sString = "C:\Users\USERNAME" & @CRLF & _
"C:\Users\USERNAME\Desktop" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderB" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderC" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderD" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderB" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderC" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderD" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderB" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderC" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderD" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderA" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderB" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderC" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderD" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderB\level3a" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderB\level3b" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderB\level3c" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderB\level3d" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderC\level3a" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderC\level3b" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderC\level3c" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderC\level3d" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderD\level3a" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderD\level3b" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderD\level3c" & @CRLF & _
"C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderD\level3d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")