use strict;
my $str = 'C:\\Users\\USERNAME
C:\\Users\\USERNAME\\Desktop
C:\\Users\\USERNAME\\Desktop\\level1
C:\\Users\\USERNAME\\Desktop\\level1\\folder
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderB
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderC
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderD
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderB
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderC
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderD
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderB
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderC
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderD
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderA
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3a
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3b
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3c
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3d
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3a
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3b
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3c
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3d
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3a
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3b
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3c
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3d';
my $regex = qr/(C:(?:\\.+){8}(?:\\|\n|$))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}