package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)(C:(?:\\.+){8}(?:\\|\n|$))`)
var str = `C:\Users\USERNAME
C:\Users\USERNAME\Desktop
C:\Users\USERNAME\Desktop\level1
C:\Users\USERNAME\Desktop\level1\folder
C:\Users\USERNAME\Desktop\level1\folder\folderA
C:\Users\USERNAME\Desktop\level1\folder\folderB
C:\Users\USERNAME\Desktop\level1\folder\folderC
C:\Users\USERNAME\Desktop\level1\folder\folderD
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderB
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderC
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderD
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderB
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderC
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderD
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderA
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderB
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderC
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderD
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderB\level3a
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderB\level3b
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderB\level3c
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderB\level3d
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderC\level3a
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderC\level3b
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderC\level3c
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderC\level3d
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderD\level3a
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderD\level3b
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderD\level3c
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderD\level3d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}