import re
regex = re.compile(r"(C:(?:\\.+){8}(?:\\|\n|$))")
test_str = ("C:\\Users\\USERNAME\n"
"C:\\Users\\USERNAME\\Desktop\n"
"C:\\Users\\USERNAME\\Desktop\\level1\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderB\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderC\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderD\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderB\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderC\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderD\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderB\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderC\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderD\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderA\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3a\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3b\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3c\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3d\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3a\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3b\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3c\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3d\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3a\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3b\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3c\n"
"C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3d")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")