import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(C:(?:\\\\.+){8}(?:\\\\|\\n|$))";
final String string = "C:\\Users\\USERNAME\n"
+ "C:\\Users\\USERNAME\\Desktop\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderB\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderC\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderD\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderB\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderC\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderD\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderB\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderC\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderD\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderA\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3a\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3b\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3c\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3d\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3a\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3b\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3c\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3d\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3a\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3b\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3c\n"
+ "C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3d";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}