import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"(C:(?:\\.+){8}(?:\\|\n|$))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
C:\Users\USERNAME
C:\Users\USERNAME\Desktop
C:\Users\USERNAME\Desktop\level1
C:\Users\USERNAME\Desktop\level1\folder
C:\Users\USERNAME\Desktop\level1\folder\folderA
C:\Users\USERNAME\Desktop\level1\folder\folderB
C:\Users\USERNAME\Desktop\level1\folder\folderC
C:\Users\USERNAME\Desktop\level1\folder\folderD
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderB
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderC
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderD
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderB
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderC
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderD
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderA
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderB
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderC
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderD
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderB\level3a
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderB\level3b
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderB\level3c
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderB\level3d
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderC\level3a
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderC\level3b
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderC\level3c
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderC\level3d
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderD\level3a
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderD\level3b
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderD\level3c
C:\Users\USERNAME\Desktop\level1\folder\folderA\folderA\folderA\folderD\level3d
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)