// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?U)(C:(?:\\.+){8}(?:\\|\n|$))").unwrap();
let string = "C:\\Users\\USERNAME
C:\\Users\\USERNAME\\Desktop
C:\\Users\\USERNAME\\Desktop\\level1
C:\\Users\\USERNAME\\Desktop\\level1\\folder
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderB
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderC
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderD
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderB
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderC
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderD
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderB
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderC
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderD
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderA
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3a
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3b
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3c
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3d
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3a
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3b
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3c
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3d
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3a
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3b
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3c
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3d";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}