const regex = /(C:(?:\\.+){8}(?:\\|\n|$))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(C:(?:\\\\.+){8}(?:\\\\|\\n|$))', 'g')
const str = `C:\\Users\\USERNAME
C:\\Users\\USERNAME\\Desktop
C:\\Users\\USERNAME\\Desktop\\level1
C:\\Users\\USERNAME\\Desktop\\level1\\folder
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderB
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderC
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderD
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderB
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderC
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderD
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderB
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderC
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderD
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderA
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3a
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3b
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3c
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderB\\level3d
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3a
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3b
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3c
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderC\\level3d
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3a
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3b
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3c
C:\\Users\\USERNAME\\Desktop\\level1\\folder\\folderA\\folderA\\folderA\\folderD\\level3d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}