#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<(?:(?!br\s*>|br\s*\/>)[^>'"]*|(['"]).*?\1)*>"
Local $sString = "THis is a test <p>paragraph</p>Let's Jump<br>" & @CRLF & _
"haha It worked !!! :P<wuuut>" & @CRLF & _
"This BR won't be matched <BR/>" & @CRLF & _
"<b>That cool :)</b>" & @CRLF & _
"This is more reliable <br />" & @CRLF & _
"<a>as you can see</a><Br />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")