use strict;
my $str = 'THis is a test <p>paragraph</p>Let\'s Jump<br>
haha It worked !!! :P<wuuut>
This BR won\'t be matched <BR/>
<b>That cool :)</b>
This is more reliable <br />
<a>as you can see</a><Br />';
my $regex = qr/(?i)<(?:(?!br\s*>|br\s*\/>)[^>'"]*|(['"]).*?\1)*>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}