import Foundation
let pattern = #"(?i)<(?:(?!br\s*>|br\s*\/>)[^>'"]*|(['"]).*?\1)*>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
THis is a test <p>paragraph</p>Let's Jump<br>
haha It worked !!! :P<wuuut>
This BR won't be matched <BR/>
<b>That cool :)</b>
This is more reliable <br />
<a>as you can see</a><Br />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)