$re = '/(?i)<(?:(?!br\s*>|br\s*\/>)[^>\'"]*|([\'"]).*?\1)*>/';
$str = 'THis is a test <p>paragraph</p>Let\'s Jump<br>
haha It worked !!! :P<wuuut>
This BR won\'t be matched <BR/>
<b>That cool :)</b>
This is more reliable <br />
<a>as you can see</a><Br />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);