import re
regex = re.compile(r"(?i)<(?:(?!br\s*>|br\s*\/>)[^>'\"]*|(['\"]).*?\1)*>")
test_str = ("THis is a test <p>paragraph</p>Let's Jump<br>\n"
"haha It worked !!! :P<wuuut>\n"
"This BR won't be matched <BR/>\n"
"<b>That cool :)</b>\n"
"This is more reliable <br />\n"
"<a>as you can see</a><Br />")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")