const regex = /(?i)<(?:(?!br\s*>|br\s*\/>)[^>'"]*|(['"]).*?\1)*>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)<(?:(?!br\\s*>|br\\s*\\\/>)[^>\'"]*|([\'"]).*?\\1)*>', 'g')
const str = `THis is a test <p>paragraph</p>Let's Jump<br>
haha It worked !!! :P<wuuut>
This BR won't be matched <BR/>
<b>That cool :)</b>
This is more reliable <br />
<a>as you can see</a><Br />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}